Mono 4.0 et les sentinelles sur raspberry


#1

Bonjour,

Mon problème est que quand je lance cette ligne de code dans ma console sur raspberry:
wget -O install.sh https://developer.myconstellation.io/download/installers/install-linux.sh && chmod +x install.sh && ./install.sh
pour check que tout est à jour et lancer ma sentinelle, MONO étant de version 4.0 sur ma raspberry , ma console me dit que MONO est installé mais que le système minimum d’exploitation MONO n’a pas été trouver.

Je n’arrive pas à passer de MONO 4.0 à 3.10 donc dans ce cas, avez vous une solution ? Es-ce du à MONO 4.0 ou un problème de ma part ?

Bonne journée


#2

Il faut au min. Mono 3.10 pour une sentinelle et 3.12 pour un serveur.

Le problème c’est que le repository de Raspbian contient une version obsolète de Mono. Il ne faut donc pas installer Mono AVANT Constellation, du moins pas à partir du repository officiel de Raspbian.

En effet, le WPI Constellation ajoute le repository officiel de Xamarin dans la liste des depots APT pour lancer l’installation de Mono dans sa dernière version.

Si toutefois, Mono est déjà installé depuis la source Raspbian, très compliqué de le désintaller! Le plus simple étant de réinstaller Raspbian from scratch et lancer le WPI Constellation pour le laisser installer la bonne version.