[linux] problème d'installation


#1

Bonjour suite à la mise en place de ma plate forme domotique, j’ai décidé d’installer constellation sur mon Rasp pi2.
Je pratique très peu sur linux alors j’ai quelques difficultés.
J’ai réussi à lancer l’install et à suivre la procédure indiqué dans le tuto mais voilà je me retrouve avec une erreur dans les log console :

[Server/AuthentificationMiddleware] 10:17:21 : Access Denied (Forbidden 403) for 192.168.1.27. Sentinel='raspberrypi' Package='Sentinel' AccessKey='d
d94709528bb1c83d08f3088d4043f4742891f4f' URI='[[!;;http://192.168.1.27:8088/signalr/negotiate?clientProtocol=1.4&connectionData]=[{"Name":"SentinelHub"}]']

J’ai un peu tout éssayé et à la force j’ai du foutre un beau bordel dans le système.
Je cherche donc des infos pour :
Désinstaller constellation pour ensuite réinstaller constellation proprement.

Ensuite si on peut m’indiqué pourquoi j’ai ce pb d’erreur 403 pour ne pas l’avoir à nouveau…

Merci par avance pour votre aide et bon weekend


#2

Hello,

Cette erreur indique que la sentinelle ici nommée “raspberrypi” tente de se connecter sur ta Constellation avec l’access key “dd94709528bb1c83d08f3088d4043f4742891f4f”.

Il faut donc que tu vérifies que cette sentinelle soit bien déclarée sur ta Constellation avec le credential dont l’Access key est “dd94709528bb1c83d08f3088d4043f4742891f4f”. Tu peux faire tout ça en utilisant la Console Constellation (page Sentinels + Manage Credentials) ou directement depuis le fichier de configuration XML.

Autrement pour désinstaller Constellation de ta RPi :

    Arrêter supervisor : sudo /etc/init.d/supervisor stop
    Supprimer les services Constellation de supervisor soit sudo rm -Rf /etc/supervisor/conf.d/constellation-*
    Supprimer les fichiers Constellation soit sudo rm -Rf /opt/constellation-*
    Relancer supervisor : sudo /etc/init.d/supervisor start

Voilà Constellation complètement supprimé du système ! Tu peux ensuite relancer le WPI pour réinstaller !


#3

Super merci pour toute ton aide (comme d’hab).
Je vais testé tous ça de suite.


#4

Ca marche impec, j’ai du loupé un truc à la première install.
Aller maintenant j’install mes packages et ensuite plus qu’a remettre mon UI.
Aller ça avance merci pour ton aide.