Installation raspberry armV6


#1

Bonjour,

pour faire des tests, j’ai ressorti un raspberry pi 1 en armv6 et j’ai un problème d’installation de mono. En effet, les architectures armv6 sont gérés à part dans le script et c’est une version 3.10 spéciale de mono qui est installée… sauf que le serveur requiert une 3.12 mini !
Dois-je abandonner l’idée ? me lancer dans une compilation des dernières sources de mono sur mon raspberry ? … ?


#2

Bonjour,

Oui en effet, sur arm6 pas de serveur, juste une sentinelle.

Je cite :

Ceci dit il est important de se rappeler des prérequis pour ces deux composants Constellation :

  • Le serveur Constellation nécessite au minimum Mono 3.12
  • La sentinelle Constellation nécessite au minimum Mono 3.10

Or Mono 3.12 et + n’est pas stable sur une architecture ARMv6. Le Web Platform Installer Linux installera automatiquement la dernière version de Mono à l’exception des architectures ARMv6 pour lequel il installera la version 3.10, la seule stable (à ce jour du moins) sur ce type d’architecture.

Autrement dit :

  • La sentinelle Constellation peut être installée sur tous les Raspberry Pi
  • Le serveur Constellation ne peut être installé que sur un Raspberry Pi B version 2 ou version 3

Bien à vous